В диалоговом окне «Предопределенные параметры и значения» убедиться, что в раскрывающемся списке «Имя параметра» выбрана точка доступа «060» и нажать OK. Специфика работы динамического протокола практически исключает вероятность того, что два устройства получат одинаковый IP-адрес, что часто случается в ситуации ручного набора статистического IP;. Теперь нам нужно сохранить настройки, если этого не сделать то при перезагрузке или при внештатном отключение электропитания, настройки с нашего роутера пропадут и все придется делать заново.
DHCP сервер, клиент: что это, настройка на роутере простыми словами, включение и отключение
В предыдущих частях цикла материалов «Локальная сеть своими руками», мы с вами узнали: из каких компонентов и устройств состоит домашняя компьютерная сеть, на какие детали и характеристики в первую очередь стоит обращать свое внимание при выборе маршрутизатора, а так же разобрались с разновидностями сетевых кабелей и научились изготавливать их самостоятельно.
В этом материале мы рассмотрим лишь основные настройки маршрутизаторов, позволяющие привести в рабочее состояние домашнюю локальную сеть. На самом деле, роутеры могут иметь очень широкую функциональность, а количество настроек в продвинутых моделях слишком велико, что бы рассмотреть их все в рамках одной статьи.
Не смотря на то, что практически все современные роутеры имеют специальные режимы «для чайников», позволяющие осуществлять установку его основных параметров в несколько коротких этапов, без определенных знаний и понимания некоторых терминов, даже в таком виде настройка маршрутизатора может оказаться непосильной задачей.
Наверное, новичкам в этом деле, самое время развести руками, но отчаиваться пока не стоит. Как бы не ухищрялись программисты и производители, все же по основным общепризнанным терминам всегда можно понять, за что отвечает та или иная опция в меню настроек маршрутизатора.
Так что, разобравшись с базовыми понятиями, используемыми в прошивках роутеров, вы сможете без труда корректно настроить его основные параметры под конкретные цели и задачи. Тем более, большинство ошибок совершается именно из-за того, что различные опции роутера часто настраиваются без понимания тех функций, за которые они отвечают.

[expert_bq id=»5263″]Из-за этого динамического назначения IP-адреса меньше вероятность того, что два устройства будут иметь один и тот же IP-адрес , который очень легко запускается при использовании статических IP-адресов, назначенных вручную. Если у вас не выходит разобраться в проблеме, пишите мне![/expert_bq]
DHCP что это такое
Синтаксис конфигурации Netplan
Новичкам синтаксис конфигурационного файла Netplan может показаться запутанным, но разобраться в нём вполне можно. Он чем-то напоминает JSON, но не имеет таких жёстких ограничений:
поле0 :поле1 : значениеполе2 :— элемент1— элемент2— элемент3
Имя поля и его значение разделяется двоеточием. В качестве значения поля можно передавать не только текстовое или числовое значение, но и другое поле, несколько полей или список значений. При передаче списка каждый новый элемент списка должен начинаться с дефиса.
network :version : 2renderer : программа_бэкендвид_интерфейса :имя_интерфейса :параметр : значение
Первые две строчки конфигурации стандартны. Первая указывает, что мы будем иметь дело с сетью, а вторая указывает версию стандарта конфигурации, которая будет использоваться. Их лучше не трогать.
- renderer — указывает программу, для которой будут преобразоваться ваши настройки. На данный момент поддерживаются только network-manager и systemd-networkd;
- вид_интерфейса — вид сетевых интерфейсов, которые вы будете настраивать в этой секции. Они делятся на физические: ethernets (проводные), wifis (беспроводные) и виртуальные: vlans , bonds, bridges.
- имя_интерфейса — имя сетевого интерфейса в системе, например enp3s0 или eth0;
- параметры — настройки, с помощью которых указывается, как нужно подключаться к сети.

Для каждого клиента DHCP-сервер заводит в своей базе запись с параметрами конфигурации. Каждой записи соответствует уникальный ключ (например, ). Поддерживаемые параметры конфигурации определены в RFC 1122, RFC 1123, RFC 1196, RFC 1256. DHCP-сервер проверяет правильность адреса клиента но не наличие аренды и отправляет DHCPACK с требуемыми параметрами конфигурации. Птичка в конце говорит нам о том, что мы в не привилегированном режиме, об этом мы будем говорить позже, сейчас нам важно понимать, что в таком режиме роутер не даст себя настраивать.
Используем DHCP в локальной сети
Для настройки DHCP в домашней сети нужно сделать следующее:
- зайти в роутер как администратор (логин и пароль обычно – admin);
- найти настройки DHCP внутри консоли роутера;
- выбрать опцию включения DHCP;
- после активации DHCP выбрать диапазон IP-адресов для локальных клиентов (например, от 192.168.1.100 до 192.168.1.200). Роутер обычно подсказывает вам начальный адрес, маску подсети, и список адресов, который DHCP-сервер может выделить из всех возможных);
- выберите необходимое время аренды IP-адреса – этот параметр показывает время сохранения определённого IP-адреса за выключенным устройством (когда последнее не в сети). Когда устройство вновь присоединяется к сети, оно автоматически получит зарезервированный за ним IP-адрес.
- кликаем правой клавише мыши на значок сетевого подключения (справа снизу);
- выбираем центр управления сетями;
- затем жмём на «подключение по локальной сети» или «беспроводное сетевое подключение»;
- в появившемся меню выбираем «свойства»;
- жмём дважды на протокол интернета 4 версии;
- активизируем пункты напротив автоматического получения IP-адреса и DNS;
- жмём «Ок».

DHCP сервер, клиент: что это, настройка на роутере простыми словами, включение и отключение
- Первый элемент (DHCP-сервер) устанавливает нужные параметры конфигурации сети, присваивает и обновляет адреса для присоединяющихся или покидающих сеть устройств.
- Другой (DHCP-клиент) подключается к сети, получает от сервера сетевые параметры, и начинает работать. Набор DHCP-параметров включает диапазон доступных IP-адресов, соответствующую маску подсети, шлюз сети и имя для серверных адресов.
Ограничения DHCP
Оба устройства (клиент и сетевой шлюз) должны поддерживать DHCP и активировать работу данного протокола. При этом сервер DHCP не распознаёт устройство, на котором ручным путём установлен IP-адрес, входящий в диапазон заданных IP-адресов сервера. Такая ситуация обычно приводит к конфликту IP-адресов и сбоев в работе сети.
- Для подключения к сети компьютер или любое другое устройство должно быть настроено должным образом. С тех пор, как использование DHCP позволило автоматическую настройку конфигурации, практически каждый девайс может легко подключаться к сети, включая компьютеры, свичи, смартфоны, приставки и так далее;
- Специфика работы динамического протокола практически исключает вероятность того, что два устройства получат одинаковый IP-адрес, что часто случается в ситуации ручного набора статистического IP;
- Использование DHCP значительно облегчает настройку сети для администраторов, вследствие автоматической раздачи адресов сервером.
- Поскольку IP устанавливаются автоматически, устройства могут свободно переключаться между разными сетями без необходимости прописывать все параметры вручную;
- для различных сетевых устройств (например, сетевых принтеров) достаточно непрактичным выглядит постоянная смена IP для них. Потому за такими устройствами лучше сохранять статистический IP-адрес;
- то же самое касается случаев, когда вы имеете постоянный удалённый доступ к компьютеру с помощью специальных программ, привязанных к определённому IP-адресу. Для такого доступа вам понадобится статистический IP, а не динамический IP.
